Bluestone PIM - Bluestone PIM UI shows error message – Incident details

Third Party: MongoDB → MongoDB Cloud experiencing partial outage

Bluestone PIM UI shows error message

Resolved
Major outage
Started about 1 month agoLasted about 1 hour

Affected

EU Regional Services Status

Major outage from 2:20 PM to 3:17 PM

General Services

Major outage from 2:20 PM to 3:17 PM

Main UI

Major outage from 2:20 PM to 3:17 PM

US Regional Services Status

Major outage from 2:20 PM to 3:17 PM

General Services

Major outage from 2:20 PM to 3:17 PM

Main UI

Major outage from 2:20 PM to 3:17 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating
    We are currently investigating this incident.

    WOI-2026-05-12-BluestonePIMUIdowntimeincidentreport-130526-1031-120.pdf